Unresponsive UI on Arbitum

Greetings - just saw this and tried in a few browsers but haven’t done a deep debugging dive yet but…

When trying to interact with the pickle site on Arbitum the UI is unresponsive when trying to claim pickles or unstake from a jar. I’m seeing an uncaught promise error and lots of rpc errors with metamask. I should be in the latest chrome + metamask, although I have also tried in Brave & Firefox.

Maybe this is just me - the world is often against me, but if not then I thought I’d report it. I’ll see what I can grab from the console and add to this but wondering if others have encountered this.

Here what I see in the console:

Uncaught (in promise) Error: network does not support ENS (operation=“ENS”, network=“arbitrum”, code=UNSUPPORTED_OPERATION, version=providers/5.4.0)
at p.makeError (index.js:185)
at p.throwError (index.js:194)
at c. (base-provider.js:1383)
at Generator.next ()

And then recurring Metamask RPC errors…

inpage.js:1 MetaMask - RPC Error: Internal JSON-RPC error. {code: -32603, message: ‘Internal JSON-RPC error.’, data: {…}}
at o (base-provider.js:5)

Hitting a harvest & exit UI element (for example) throws:

instrument.js:109 {code: -32603, message: ‘Internal JSON-RPC error.’, data: {…}, stack: ‘{\n “code”: -32603,\n “message”: "Internal JSON-RP…eogaeaoehlefnkodbefgpgknn/background-1.js:1:12923’}